Issue 12639

occurrence download: only admins can download successfully

Reporter: kbraak
Assignee: mdoering
Type: Bug
Summary: occurrence download: only admins can download successfully
Priority: Major
Resolution: Fixed
Status: Closed
Created: 2013-01-24 14:51:19.978
Updated: 2013-08-29 14:44:50.842
Resolved: 2013-01-25 10:56:37.32
Description: I have tried using username="Kyle Braak but repeated downloads are unsuccessful. For example, job with id:


failed during the copy_and_zip action due to: File does not exist: /user/hive/warehouse/download_tmp_KyleBraak_9acbcfe2efbe4df1a30feb19c827ca0e

In the job config, the file name corresponds OK with:


The actual root of the problem could be the space in the user name. I haven't been able to try and run a download with another non-admin user yet, because download is currently broken.

Screenshot of job info, and job logs included with issue.

Attachment Screen Shot 2013-01-24 at 2.44.01 PM.png

Attachment jobLog.txt

Comment: that was one reason for having user account name restrictions - please try with another user account with small latin letters 0-9 or ._- only
Created: 2013-01-24 14:54:32.826
Updated: 2013-01-24 14:54:32.826

Comment: Just tried with account "jose" and it succeeded, although the zipped archive still leads to a 404.
Created: 2013-01-25 10:53:24.023
Updated: 2013-01-25 10:53:24.023

Created: 2013-01-25 10:56:37.343
Updated: 2013-01-25 10:56:37.343
So, we can assume this issue has something to do with my user name having a space. Restricting the user names inherently fixes this issue.