Issue 10744

Issue organizing occurrences of Thlapsi

Reporter: trobertson
Assignee: mdoering
Type: Bug
Summary: Issue organizing occurrences of Thlapsi
Priority: Minor
Resolution: WontFix
Status: Closed
Created: 2012-02-02 15:27:02.902
Updated: 2016-05-11 16:00:55.266
Resolved: 2016-05-11 16:00:55.154
Description: By email from Herbario SANT :

a visitor to our herbarium just discovered something odd in our
data when making this search:[0].s=20&c[0].p=0&c[0].o=3052635&c[1].s=25&c[1].p=0&c[1].o=66&c[2].s=13&c[2].p=0&c[2].o=SANT

That search only returns 8 records of "Thlaspi arvense", but it should
be returning 38 of many other specimens belonging to genus "Thlaspi".
For example, this one:
Actually, our tapirlink interface returns 38 records. I have checked
the original table and all of them have identical values in higher
taxonomic concepts (genus, family, ...)

This happens when searching by "Classification includes Genus: Thlaspi".
It also happens when searching by "Scientific name is Thlaspi" (only
the 8 records of "Thlaspi arvense" being returned)
If I search for the non-returned records using a different filter,
like "Catalogue number is 1602", there is no problem. They are

If I order our table by catalognumber, the first matched record
belongs to "Thlaspi arvense" (the only scientificname which is being
returned by

The oddest thing is that I cannot reproduce the same behaviour when I
query for some other genus (only in Thlaspi by now).
Why is this happening? Am I missing something?  Could be something
related to a cache somewhere?


PS - I just tried to add more collectioncodes to the same search and,
add one more species of Thlaspi, to see what happens:[0].s=0&c[0].p=0&c[0].o=Thlaspi&c[1].s=0&c[1].p=0&c[1].o=Thlaspi

I can understand what's going on:
- SALA seems to work well (returns all species of Thlaspi when
searching for "Scientific name is Thlaspi")
- SANT and LEB-Cormo do the same odd thing (just return Thlaspi
arvense, and I need to add other species like Thlaspi perfoliatum, in
order to get them in dataset)
- Herbarium Berolinense is returning all kind of stuff: both Thlaspi
(correctly, all species), but also other non requested genus which
belong to the same family (like Aethionema). A mistery

Herbario SANT
Facultade de Farmacia - Laboratorio de Botánica
Universidade de Santiago de Compostela
15782 - Galicia (Spain)
Tel. +34 881815022
Fax +34 981594912]]>

Created: 2012-02-02 16:00:52.623
Updated: 2012-02-02 16:00:52.623
Trying to investigate into the problem. The nub only has a single concept for both the genus Thlaspi and the species T. arvense:

Doing a new search starting with the GBIF concept of Thlaspi and adding 4 datasets (SANT,SALA,LEB-Como&Berolinense) I get

It appears the "missing" specimen like the following are not tight to the GBIF taxonomy for some reason:

It says "GBIF classification", but in fact the species id given and linked leads to the native taxonomy of the occurrence dataset:

When trying to link this record manually to our "nub" taxonomy it is correct when using the name without classification:
nubId=3050634, confidence=44

With the genus & family brassicaceae (the one used in the nub) it is:
nubId=3050634, confidence=95

When using the exact same occurrence classification with family=Cruciferae it is still the same:
nubId: 3050634, confidence: 95,

A bit clueless why this has happened...

Created: 2012-02-02 16:03:16.945
Updated: 2012-02-02 16:03:16.945
Thlaspi perfoliatum L. is considered a synonym of Microthlaspi perfoliatum:

Maybe thats why it gets excluded from a taxonomic Thlaspi search? Its not a lexical search

Created: 2012-02-02 16:16:02.153
Updated: 2012-02-02 16:16:02.153
Indeed.  Here it is: which does synonymy expansion automatically.

That single specimen is tied in the database to the nub concept of Thlaspi perfoliatum L. (


Created: 2016-05-11 16:00:55.247
Updated: 2016-05-11 16:00:55.247
Closing as exluding the Thlaspi perfoliatum synonym from a Thlaspi genus search seems like the correct and expected behavior.

Current link to the specimen: